Showing results for 
Search instead for 
Did you mean: 
New Member - Level 1

Problem with expense report submission

Hi, I have a problem with my expense report submission. The system is giving me an error that my banking details are not submitted in Touchstone Amazon, while I have submitted my details (on Touchstone Amazon) more than 48 hours ago. My banking details there is confirmed, as a transaction was successful to confirm my account.


I have tried:

- Logging in and out several time and submitting the report

- Copying the report into another and resubmitting

- Deleting the report and recreating a new one and resubmitting.


All gave me the same error.


Anyone has any idea how to fix this problem?


Community Manager
Community Manager

@jasriri it is likely that the details from Touchstone haven't fed to SAP Concur yet. I would give it another day or two. If it doesn't update, then I suggest speaking with your manager to see if they can help you get some internal help. 


Unfortunately most people here on the Community don't use an external site to enter bank details and Touchstone is specific to Amazon, so we can only really speculate on the issue.

Thank you,
Kevin Dorsey
SAP Concur Community Manager
Did this response answer your question? Be sure to select “Accept as Solution” so your fellow community members can be helped by it as well.