cancel
Showing results for 
Search instead for 
Did you mean: 
JeffHaracz
Occasional Member - Level 1

Future Date

What paramenters are used in an Audit Rule to prevent usage of future dates?  I have experience with this from a previous instance but my new employer does not have this audit rule.  I thought this was a default rule and I cannot seem to get the logic correct to re-create it.

1 Solution
Solution
KevinD
Community Manager
Community Manager

@JeffHaracz what is the name of your new company? Normally, the future dated transactions is a rule that is automatically turned on. It's possible that its active status might be set to No. 

 

On the off chance the rule just isn't there, I've provided a screenshot of what the rule conditions should look like. 

 

Future_Date.jpg

 

I hope this helps.

 

Kevin


Thank you,
Kevin Dorsey
SAP Concur Community Manager
Did this response answer your question? Be sure to select “Accept as Solution” so your fellow community members can be helped by it as well.

View solution in original post

13 REPLIES 13
Solution
KevinD
Community Manager
Community Manager

@JeffHaracz what is the name of your new company? Normally, the future dated transactions is a rule that is automatically turned on. It's possible that its active status might be set to No. 

 

On the off chance the rule just isn't there, I've provided a screenshot of what the rule conditions should look like. 

 

Future_Date.jpg

 

I hope this helps.

 

Kevin


Thank you,
Kevin Dorsey
SAP Concur Community Manager
Did this response answer your question? Be sure to select “Accept as Solution” so your fellow community members can be helped by it as well.
JeffHaracz
Occasional Member - Level 1

Ace Hardware.  Yeah, I thought it was a preset rule.  I don't see it in incative rules.  I did find this info on another thread but was unsure about the 'Within Today + 10000'.  What is this referencing in terms of data?

 

Thanks

Jeff

KevinD
Community Manager
Community Manager

It's referencing the transaction date. So, within today means today's date then the +10000 means transaction dates 10000 days in the future. So, if an expense has a date that is anywhere from tomorrow out to 10000 days, it will get flagged. 

 

The Not Within and Within with the + or - tends to sometimes confuse people. 

 

Kevin


Thank you,
Kevin Dorsey
SAP Concur Community Manager
Did this response answer your question? Be sure to select “Accept as Solution” so your fellow community members can be helped by it as well.
JeffHaracz
Occasional Member - Level 1

Got it.  Thanks for your help.

MariannaLMD
New Member - Level 1

We are a distributed company and we have users in all time zones. My users in Australia (the main company is in the US Pacific time zone) complain that they are not able to enter expenses of today's date when it is "today" in Australia and "yesterday" in the US Pacific zone. How to resolve this issue? is it related to Future date rules? Thanks!

@MariannaLMD this shouldn't be happening. Can you please send me your company's full name. I'd like to take a look and see if there was something changed in the audit rule. Can you also provide me an employee name that this is happening to? 

 

It might be best to send this information in a private message.

 

Kevin


Thank you,
Kevin Dorsey
SAP Concur Community Manager
Did this response answer your question? Be sure to select “Accept as Solution” so your fellow community members can be helped by it as well.
DeanR
Routine Member - Level 3

Hi @KevinD ,

We have the same experience with the audit rule as described by @MariannaLMD.  We're a wholly Australia-based company but our data is in the North America Data Center.  If our users try to enter an expense in the morning (local time) with the current day's date they will get this error; later in the same day they can enter it without error.

KevinD
Community Manager
Community Manager

@DeanR can you send me your company name in a private message, please? I'd like to take a look. 

 

Thank you,

Kevin


Thank you,
Kevin Dorsey
SAP Concur Community Manager
Did this response answer your question? Be sure to select “Accept as Solution” so your fellow community members can be helped by it as well.
DeanR
Routine Member - Level 3

The Audit Rule needs to be improved to something more robust than today's date + x days.  We've had users transpose the year data incorrectly (e.g. year 2109 instead of 2019) and the Audit Rule has allowed it.

 

There is an existing Solution Suggestion SS-0000023698 for this: https://concur.secure.force.com/CteSupport/ideas/viewIdea.apexp?id=0870e000000Tj8P

 

mbrunton
Occasional Member - Level 1

I get exactly the same issue - in our timezone, we are GMT+10 hours. If I enter any expenses before the date changes in UTC, then I get 2 warnings. One says that I can't enter future dated expenses, and the other says it is routing for additional manager approval as my expense is more than 2 years old. It seems like the futuredate check is not being performed in my local time, but on the UTC date. When the UTC date ticks over (funnily enough, this happens at 10am!) then everything is ok, but I have to go in and resave the expense, which is a bit of a nuisance!

KevinD
Community Manager
Community Manager

@mbrunton I've seen this happen when the data center your instance of SAP Concur sits in is a different time zone than where you physically reside. I'm trying to remember if there was a workaround for this or not. Maybe update your personal profile settings to match UTC time. 


Thank you,
Kevin Dorsey
SAP Concur Community Manager
Did this response answer your question? Be sure to select “Accept as Solution” so your fellow community members can be helped by it as well.
mbrunton
Occasional Member - Level 1

Thanks very much for your suggestion. I tried setting my timezone to UTC in system settings and putting in a test expense, but I still get the same 2 warnings. I am not too sure where our servers are hosted - most likely the US, but I am based in Australia.

 

Thanks,

 

Matt

KevinD
Community Manager
Community Manager

@mbrunton maybe try entering a U.S. time zone. See if that works. Other than that, I don't recall if there is workaround or not.


Thank you,
Kevin Dorsey
SAP Concur Community Manager
Did this response answer your question? Be sure to select “Accept as Solution” so your fellow community members can be helped by it as well.