cancel
Showing results for 
Search instead for 
Did you mean: 
inwaogwugwu
Occasional Member - Level 1

Concur file 305 import error

Hello All,

 

I received below error while loading Concur 305 Employee file. The record is for the only Japanese employee:

 

Field ‘first_name’ contained one or more invalid characters.

 

Please assist

10 REPLIES 10
cesnjuli
Occasional Member - Level 3

Are there any special characters in the name? Is encoding correct? Are you sure that there are no Space in from of the name? 

inwaogwugwu
Occasional Member - Level 1

There are special characters in the name, but there is no space before the name.

 

Thanks

cesnjuli
Occasional Member - Level 3

And that special character is which character?

inwaogwugwu
Occasional Member - Level 1

This is a Japanese employee and all the First name are special characters.

cesnjuli
Occasional Member - Level 3

Hmm.. I assume by special characters you mean  Japanese letters, which is not correct.

These are special characters I had in mind:

" !"#$%&'()*+,-./:;<=>?@[\]^_`{|}~"

 

inwaogwugwu
Occasional Member - Level 1

Yes. They are japanese characters.

cesnjuli
Occasional Member - Level 3

Then start with checking if file encoding is correct.

That's what Concur is saying in documentation:

if importing double-byte characters (Chinese, Japanese, etc.), the import file must be UTF-8 (Unicode) encoded; otherwise ANSI encoding is sufficient.

 

Then in addition I found the following comment:

The Client assembles the import data file, formatting it according to the specifications in this document. The import data
file specifications are as follow:
• Format Type: Comma Separated Value, UTF-8 with BOM
• Default Field Delimiter: Comma (or support for Pipe, but only by contacting SAP Concur implementation or
support teams to enable this delimiter type)
• Enclosing Character: To "escape" a reserved character, such as a slash, use a quotation mark, for example: "/"
• Record Delimiter: CRLF

 

and obviously all special character  % [ # ! * & ( ) ~ ` ' { ^ } \ | / ? > < , ; : " + = ] cannot be used in Login ID field.

 

Try  to load the list without those special characters first and add then after upload manually if encoding is correct.

inwaogwugwu
Occasional Member - Level 1

Hello,

 

I will try these steps and get back to you. Thanks.

MSTEEN
SAP Concur Employee
SAP Concur Employee

cesnjuli is correct: the import file must be UTF-8 (Unicode) encoded.  

 

In my experience, I had to work with LATAM and European names and the encoding should be correct.  Keep in mind the CTE login does not accept special characters. 

 

Try to change/correct the names with just a couple of users at a time to update the login or email fields in the import file. 

Maria Steen
seba563
New Member - Level 1

Hi, to mport all the files in Concur, we use an application called Nitby and it makes all the controls and the file conversion. It can be a solution for you as well.