Showing results for 
Search instead for 
Did you mean: 
New Member - Level 1

Receipts constantly say analyzing receipt

For about a month, whenever I upload a receipt, it is stuck in the analyzing receipt phase, and will take days if not weeks to actually finish uploading. It normally takes a minute or so to upload a receipt. There are a few other users in our company with the same issue, so I have ruled out a connectivity issue with my phone or WIFI. Would deleting the app and reinstalling help? Would that delete of the reciepts currently in there now? Any assistance would be greatly appreciated.

Occasional Member - Level 1

I've been having the same issue recently. None of my receipt can be added through the app. It keeps "analyzing" the receipts. Also, I'm not getting the Uber receipts automatically anymore but it used to work. I reinstalled that app as suggested from another post from 2019 and it still doesn't work on the iPhone. The workaround is to send my receipts to "" but I'd rather avoid doing this. 

Community Manager
Community Manager

@rainmelk have you tried shutting down your phone and rebooting? You can also email receipts to: if you want to have the benefit of ExpenseIt turning the receipt image into an expense entry. 

Thank you,
Kevin Dorsey
SAP Concur Community Manager
Did this response answer your question? Be sure to select “Accept as Solution” so your fellow community members can be helped by it as well.
Occasional Member - Level 1

I do shut down my phone many times. Reinstalled the app. Same issue. Actually just reopened the app tonight as it's been 4-5 days I did not use it and my receipts are still showing a scan animation with "analyzing receipt". Using iOS 15.4.1 on iPhone 12.