cancel
Showing results for 
Search instead for 
Did you mean: 
Malfeus
New Member - Level 1

Unable to Link American Express to Concur for Expense Reports

I have tried to get my AMEX linked to my Concur account. I get the following error every time. American Express denies it is there issue. 

 

Updated Information Required

We couldn't complete your request because the American Express Business Cards (@ work) site asks that you verify your personal details. Please visit the site and follow the prompts to update your information. Once updated  you can tap REFRESH to continue (Error 429). 

 

So when I click the link there are no prompts. My information is updated.  

 

Note Error 429 is as follows:

The HTTP 429 Too Many Requests response status code indicates the user has sent too many requests in a given amount of time ("rate limiting"). A Retry-After header might be included to this response indicating how long to wait before making a new request.


Can anyone help. AMEX denies its their issue and SAP doesn't have chat or a phone number to call from my portal. 

9 REPLIES 9
KevinD
Community Manager
Community Manager

@Malfeus I've posted your issue internally to see if anyone can tell me what the issue might be. I'll let you know if I hear something.


Thank you,
Kevin Dorsey
SAP Concur Community Manager
Did this response answer your question? Be sure to select “Accept as Solution” so your fellow community members can be helped by it as well.
KevinD
Community Manager
Community Manager

@Malfeus I did receive a response. The first thing we want you to try is to clear your browser cache and cookies. Then, log out of SAP Concur and log back in and give it another try. If you aren't sure how to do this for your browser, you can google it. That's what I did. 🙂

 

Let me know if this fixes the issue or not.


Thank you,
Kevin Dorsey
SAP Concur Community Manager
Did this response answer your question? Be sure to select “Accept as Solution” so your fellow community members can be helped by it as well.
Wanderflora
New Member - Level 1

Hey there! I am getting the same error code. I tried clearing cache and cookies as well as logging out of everything and am still having this issue. 

@Wanderflora is this an AMEX Business Card? Have you tried using a different browser?


Thank you,
Kevin Dorsey
SAP Concur Community Manager
Did this response answer your question? Be sure to select “Accept as Solution” so your fellow community members can be helped by it as well.
Balicki
Occasional Member - Level 1

I am having the same issue with one card.  I have reached out directly to AMEX also and am waiting to hear back.  The card I am trying to link is the "Admin" account of our AMEX program, so we think that might be the issue, although it shouldn't matter.  Each card does need to have an individual log in, which this one does so I don't know why it's not working.

KevinD
Community Manager
Community Manager

@Balicki are you getting the same error as the original poster on this thread or a different error?


Thank you,
Kevin Dorsey
SAP Concur Community Manager
Did this response answer your question? Be sure to select “Accept as Solution” so your fellow community members can be helped by it as well.
Balicki
Occasional Member - Level 1

I get this message when I log into "AMEX" to try and link card:

Balicki_0-1630495498753.png

 

dvanglad
Occasional Member - Level 1

I am also having this issue - I had to delete my card from my account because it stopped syncing to my account and when I tried to re-add the card I got the "We're sorry, there was a technical problem updating your account at American Express Cards. Please try again later. (Error 409)" This happened last month as well. 

Nancyagfa
Routine Member - Level 2

In our system, if it's a corp Amex, there is a specific field that automatically joins your card to your Concur profile when the data feeds over from Amex.  Your Card Admin could tell you if there is an issue with this, since we use the employee ID to tie the card to the employee in the Concur program by that field.  There could be a disconnect and causing the failure.  Usually there is an error on the upload and it indicates the record that failed.  But the Admin for Concur would see that message, not the end user.